J2EE naming enhancements  Enhanced transaction support

Chapter 7: New Features in EAServer 4.0

J2EE security enhancements

EAServer 4.0 implements J2EE version 1.3 security requirements including the JAAS (Java Authentication and Authorization Services) API and CORBA Secure Interoperable version 2 protocol (CSIv2). CSIv2 allows security context propagation across servers to satisfy EJB 2.0 interoperability requirements. JAAS provides a framework and standard programming interface for authenticating users and assigning privileges.

For more information, see the following chapters in the EAServer Security Administration and Programming Guide:





Copyright © 2005. Sybase Inc. All rights reserved. Enhanced transaction support